re = /^[a-zA-Z][a-zA-Z0-9_]{0,29}(?:\.[a-zA-Z][a-zA-Z0-9_]{0,29})?$/
str = 'abcghi_klxyz_BCDj.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end