import re
regex = re.compile(r"^[a-zA-Z][a-zA-Z0-9_]{0,29}(?:\.[a-zA-Z][a-zA-Z0-9_]{0,29})?$")
test_str = "abcghi_klxyz_BCDj."
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")