#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Error importing row no\. (\d+):"
Local $sString = "2012-15-08 07:04 Bla bla bla blup" & @CRLF & _
"2012-15-08 07:05 *** Error importing row no. 5: The import of this line failed because bla bla" & @CRLF & _
"2012-15-08 07:05 Another text that I don't want to search..." & @CRLF & _
"2012-15-08 07:06 Another text that I don't want to search..." & @CRLF & _
"2012-15-08 07:06 *** Error importing row no. 5: The import of this line failed because bla bla" & @CRLF & _
"2012-15-08 07:07 Import has finished bla bla"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")