package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Error importing row no\. (\d+):`)
var str = `2012-15-08 07:04 Bla bla bla blup
2012-15-08 07:05 *** Error importing row no. 5: The import of this line failed because bla bla
2012-15-08 07:05 Another text that I don't want to search...
2012-15-08 07:06 Another text that I don't want to search...
2012-15-08 07:06 *** Error importing row no. 5: The import of this line failed because bla bla
2012-15-08 07:07 Import has finished bla bla`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}