# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Error importing row no\. (\d+):"
test_str = ("2012-15-08 07:04 Bla bla bla blup\n"
"2012-15-08 07:05 *** Error importing row no. 5: The import of this line failed because bla bla\n"
"2012-15-08 07:05 Another text that I don't want to search...\n"
"2012-15-08 07:06 Another text that I don't want to search...\n"
"2012-15-08 07:06 *** Error importing row no. 5: The import of this line failed because bla bla\n"
"2012-15-08 07:07 Import has finished bla bla")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.