package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\x00-\x7F]+`)
var str = `asdİöddsadfçğsdsl.xxiczixcIldsskamsdkas.m,./,m,,ççç`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}