re = /[^\x00-\x7F]+/
str = 'asdİöddsadfçğsdsl.xxiczixcIldsskamsdkas.m,./,m,,ççç'
# Print the match result
str.match(re) do |match|
puts match.to_s
end