package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(city\=(?<city>\w+)\;location\=(?<location>\w+\.\w+)\;\d+\=(?<A456789>\d+)`)
var str = `(city=ABC;location=PNX.AZ;45678=0879)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}