import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(city\\=(?<city>\\w+)\\;location\\=(?<location>\\w+\\.\\w+)\\;\\d+\\=(?<A456789>\\d+)";
final String string = "(city=ABC;location=PNX.AZ;45678=0879)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}