re = /\(city\=(?<city>\w+)\;location\=(?<location>\w+\.\w+)\;\d+\=(?<A456789>\d+)/m
str = '(city=ABC;location=PNX.AZ;45678=0879)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end