package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)CREATE TABLE.*`(\w+)``)
var str = `CREATE TABLE IF NOT EXISTS \`ocx_category\` (
...
CREATE TABLE \`ocx_category\` (
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}