$re = '/CREATE TABLE.*`(\w+)`/i';
$str = 'CREATE TABLE IF NOT EXISTS `ocx_category` (
...
CREATE TABLE `ocx_category` (
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);