re = /CREATE TABLE.*`(\w+)`/i
str = 'CREATE TABLE IF NOT EXISTS `ocx_category` (
...
CREATE TABLE `ocx_category` (
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end