package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^data:.+\/(.+);base64,(.*)$`)
var str = `data:image/jpeg;base64,/9j/4AAQSkZJRgABAgEASABIAAD/7QAsUGhvd`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}