const regex = /^data:.+\/(.+);base64,(.*)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^data:.+\\\/(.+);base64,(.*)$', '')
const str = `data:image/jpeg;base64,/9j/4AAQSkZJRgABAgEASABIAAD/7QAsUGhvd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}