const regex = /(?<!\-)\b(\d\d|\d)\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\-)\\b(\\d\\d|\\d)\\b', 'g')
const str = ` -1 0 1 10 99 100 101 1 a1 11 -1 99`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}