$re = '/(?<!\-)\b(\d\d|\d)\b/';
$str = ' -1 0 1 10 99 100 101 1 a1 11 -1 99';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);