import re
regex = re.compile(r"(?<!\-)\b(\d\d|\d)\b")
test_str = " -1 0 1 10 99 100 101 1 a1 11 -1 99"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")