import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((http|https)(\\:\\/\\/)((([a-zA-Z_\\-0-9]{1,2000})(\\.)([a-zA-Z_\\-0-9]{1,2000})(\\.)([a-zA-Z_\\-0-9]{1,16}))|(([a-zA-Z_\\-0-9]{1,2000})(\\.)([a-zA-Z_\\-0-9]{1,16})))((([\\:\\/a-zA-Z\\ _\\-%0-9\\.\\?\\=]{1,3000})|(\\/)|())))";
final String string = "http://127.0.0.1:80";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}