re = /((http|https)(\:\/\/)((([a-zA-Z_\-0-9]{1,2000})(\.)([a-zA-Z_\-0-9]{1,2000})(\.)([a-zA-Z_\-0-9]{1,16}))|(([a-zA-Z_\-0-9]{1,2000})(\.)([a-zA-Z_\-0-9]{1,16})))((([\:\/a-zA-Z\ _\-%0-9\.\?\=]{1,3000})|(\/)|())))/
str = 'http://127.0.0.1:80'
# Print the match result
str.match(re) do |match|
puts match.to_s
end