package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d{1,5}([.]\d{0,2})`)
var str = `yyyy`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}