const regex = /\d{1,5}([.]\d{0,2})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{1,5}([.]\\d{0,2})', '')
const str = `yyyy`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}