$re = '/\d{1,5}([.]\d{0,2})/';
$str = 'yyyy';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);