package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\b(abc|def|pqr|stu)\b.*){3,}`)
var str = `abc def ghi jkl mno pqr stu`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}