$re = '/(?:\b(abc|def|pqr|stu)\b.*){3,}/';
$str = 'abc def ghi jkl mno pqr stu';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);