using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"!Automod(erator)?\S? approve this";
string input = @"!Automod approve this
!Automod, approve this
!Automoderator approve this
!Automoderator, approve this";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}