package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)!Automod(erator)?\S? approve this`)
var str = `!Automod approve this
!Automod, approve this
!Automoderator approve this
!Automoderator, approve this`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}