# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\(http[s]?:\/\/[\w\-\_\.\/]*)(\n)([\w\-\_\.\/]*\))"
test_str = ("FIREVISION SPORTS features incredible Microprism Technology, which creates a\n"
"glowing streak of light, day or night. When you activate your FIREVISION ball\n"
"with a pair of cool FIREVISION Frames, you reveal a glow with a range over 100\n"
"feet/30 meters. The FIREVISION football is performance engineered to generate\n"
"spiraling streaks of light whenever you turn on your FIREVISION Frames and\n"
"throw it to a friend. Put glow in your game with the power of Microprism\n"
"Technology and the FIREVISION Football!\n\n"
"\n\n"
" \n"
"**_FIREVISION Frames activate your ultra-bright glowing ball, day or night! \n"
"_**\n\n"
"\n\n"
" \n"
"**_Battery-powered FIREVISION Frames let you play for hours without stopping to charge up the glow! \n"
"_**\n\n"
"**Lights out! Game on!** \n"
"Grab a friend and fire up your game with the FIREVISION football. Glowing\n"
"bright, day or night, FIREVISION Football keeps you playing at the top of your\n"
"game! Only you and other players equipped with the awesome FIREVISION Frames\n"
"can see the incredible glowing path carved through the air by the FIREVISION\n"
"Football. Choose your team, and change the color of the glow with red or green\n"
"FIREVISION Frames. With a range over 100 feet/30 meters, the FIREVISION\n"
"Football is the ultimate ball to bring glow to your game.\n\n"
"**Fire up the field!** \n"
"Put on your FIREVISION Frames and power up to bring glow to your game. The\n"
"performance-engineered FIREVISION Football features awesome new Microprism\n"
"Technology that generates a glow, even in the light. Choose your team, and\n"
"change the color of the glow with red or green FIREVISION Frames. Then, pass\n"
"to your teammates down field up to 100 feet away, and watch the ball generate\n"
"an amazing streak of light the entire way. When you play with FIREVISION gear,\n"
"you fire up the field!\n\n"
"**Microprism Technology blazes with energy!** \n"
"Choose your team with red or green FIREVISION Frames. Whichever color you\n"
"choose, that’s the color your Football will glow. Put on your Frames, power\n"
"up, and check out the incredible glow generated by the Microprism Technology\n"
"embedded in your ball. With a range over 100 feet/30 meters, you’ve got the\n"
"power you need to fire up any game.\n\n"
"**What's In The Box?** \n"
"Football with Microprism Technology, 2 pairs of FIREVISION Frames, and\n"
"instructions.\n\n"
"\n\n"
" \n"
"**_Glow with a range of more than 100 feet/30 meters!_**\n")
subst = "\\1\\3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.