import Foundation
let pattern = #"(\(http[s]?:\/\/[\w\-\_\.\/]*)(\n)([\w\-\_\.\/]*\))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
FIREVISION SPORTS features incredible Microprism Technology, which creates a
glowing streak of light, day or night. When you activate your FIREVISION ball
with a pair of cool FIREVISION Frames, you reveal a glow with a range over 100
feet/30 meters. The FIREVISION football is performance engineered to generate
spiraling streaks of light whenever you turn on your FIREVISION Frames and
throw it to a friend. Put glow in your game with the power of Microprism
Technology and the FIREVISION Football!

**_FIREVISION Frames activate your ultra-bright glowing ball, day or night!
_**

**_Battery-powered FIREVISION Frames let you play for hours without stopping to charge up the glow!
_**
**Lights out! Game on!**
Grab a friend and fire up your game with the FIREVISION football. Glowing
bright, day or night, FIREVISION Football keeps you playing at the top of your
game! Only you and other players equipped with the awesome FIREVISION Frames
can see the incredible glowing path carved through the air by the FIREVISION
Football. Choose your team, and change the color of the glow with red or green
FIREVISION Frames. With a range over 100 feet/30 meters, the FIREVISION
Football is the ultimate ball to bring glow to your game.
**Fire up the field!**
Put on your FIREVISION Frames and power up to bring glow to your game. The
performance-engineered FIREVISION Football features awesome new Microprism
Technology that generates a glow, even in the light. Choose your team, and
change the color of the glow with red or green FIREVISION Frames. Then, pass
to your teammates down field up to 100 feet away, and watch the ball generate
an amazing streak of light the entire way. When you play with FIREVISION gear,
you fire up the field!
**Microprism Technology blazes with energy!**
Choose your team with red or green FIREVISION Frames. Whichever color you
choose, that’s the color your Football will glow. Put on your Frames, power
up, and check out the incredible glow generated by the Microprism Technology
embedded in your ball. With a range over 100 feet/30 meters, you’ve got the
power you need to fire up any game.
**What's In The Box?**
Football with Microprism Technology, 2 pairs of FIREVISION Frames, and
instructions.

**_Glow with a range of more than 100 feet/30 meters!_**
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)