#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(\|\s+[^ \t\*\n\|]+)).*(?:$|\s{2}|\t|\s+(?=\|))"
Local $sString = "qas defrefrfgregregoivn ev etrg" & @CRLF & _
"| 1|2|3" & @CRLF & _
"Scenario Outline: Eating" & @CRLF & _
" Given there are <start> cucumbers" & @CRLF & _
" When I eat <eat> cucumbers" & @CRLF & _
" Then I should have <left> cucumbers" & @CRLF & _
"" & @CRLF & _
" Examples:" & @CRLF & _
" | start | eat | left |" & @CRLF & _
" | 12 | 5 | 7 |" & @CRLF & _
" | 20 | 5 | 15 |"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")