$re = '/(?:(\|\s+[^ \t\*\n\|]+)).*(?:$|\s{2}|\t|\s+(?=\|))/m';
$str = 'qas defrefrfgregregoivn ev etrg
| 1|2|3
Scenario Outline: Eating
Given there are <start> cucumbers
When I eat <eat> cucumbers
Then I should have <left> cucumbers
Examples:
| start | eat | left |
| 12 | 5 | 7 |
| 20 | 5 | 15 |';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);