const regex = /(?:(\|\s+[^ \t\*\n\|]+)).*(?:$|\s{2}|\t|\s+(?=\|))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(\\|\\s+[^ \\t\\*\\n\\|]+)).*(?:$|\\s{2}|\\t|\\s+(?=\\|))', 'gm')
const str = `qas defrefrfgregregoivn ev etrg
| 1|2|3
Scenario Outline: Eating
Given there are <start> cucumbers
When I eat <eat> cucumbers
Then I should have <left> cucumbers
Examples:
| start | eat | left |
| 12 | 5 | 7 |
| 20 | 5 | 15 |`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}