#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!buh\d*$)[a-zA-Z0-9_-]{1,50}$"
Local $sString = "abcd" & @CRLF & _
"a1h2" & @CRLF & _
"buh" & @CRLF & _
"buh111111111111" & @CRLF & _
"buh22abcd" & @CRLF & _
"11111111111111"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")