using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!buh\d*$)[a-zA-Z0-9_-]{1,50}$";
string input = @"abcd
a1h2
buh
buh111111111111
buh22abcd
11111111111111";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}