import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!buh\\d*$)[a-zA-Z0-9_-]{1,50}$";
final String string = "abcd\n"
+ "a1h2\n"
+ "buh\n"
+ "buh111111111111\n"
+ "buh22abcd\n"
+ "11111111111111";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}