const regex = /,(?!")(?=.*")/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(',(?!")(?=.*")', 'gm')
const str = `945,"Hey You, Pikachu!",N64,1998,Simulation,Nintendo,0.83,0.06,0.93,0,1.83
1835,"The Game (XBox 360, PS2, PS3, PC Versions)",PS2,2007,Action,Activision,0.63,0.37,0,0.11,1.11`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);