# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r",(?!\")(?=.*\")"
test_str = ("945,\"Hey You, Pikachu!\",N64,1998,Simulation,Nintendo,0.83,0.06,0.93,0,1.83\n"
"1835,\"The Game (XBox 360, PS2, PS3, PC Versions)\",PS2,2007,Action,Activision,0.63,0.37,0,0.11,1.11")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.