#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "SELECT\s(.+)\sFROM\s(((?!\sWHERE).)+)(\sWHERE\s(.+))?"
Local $sString = "SELECT 1 FROM table_name AS b WHERE id=3"
Local $sSubst = "FROM $2 WHERE $5 GET $1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)