import re
regex = re.compile(r"SELECT\s(.+)\sFROM\s(((?!\sWHERE).)+)(\sWHERE\s(.+))?")
test_str = "SELECT 1 FROM table_name AS b WHERE id=3"
subst = "FROM $2 WHERE $5 GET $1"
result = regex.sub(subst, test_str)
if result:
print(result)