using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"someword\s+(?:\S+\s+){1,3}otherword";
string input = @"someword aaa otherword
someword aaa bbb otherword
someword aaa bbb ccc otherword
someword aaa bbb ccc ddd otherword
someword aaa bbb ccc ddd otherword someword aaa otherword someword aaa bbb ccc otherword someword aaa bbb ccc ddd otherword someword aaa bbb otherword
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}