import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "someword\\s+(?:\\S+\\s+){1,3}otherword";
final String string = "someword aaa otherword\n"
+ "someword aaa bbb otherword\n"
+ "someword aaa bbb ccc otherword\n"
+ "someword aaa bbb ccc ddd otherword\n"
+ "someword aaa bbb ccc ddd otherword someword aaa otherword someword aaa bbb ccc otherword someword aaa bbb ccc ddd otherword someword aaa bbb otherword\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}