#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\(seção: (?'secao'\d+), aptos: (?'aptos'\d+)\)"
Local $sString = "(seção: 509, aptos: 121)" & @CRLF & _
"(seção: 517, aptos: 118)" & @CRLF & _
"(seção: 327, aptos: 89), (seção: 328, aptos: 90)" & @CRLF & _
"(seção: 371, aptos: 89), (seção: 520, aptos: 53)" & @CRLF & _
"(seção: 331, aptos: 111), (seção: 332, aptos: 111), (seção: 334, aptos: 111)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")