import re
regex = re.compile(r"\(seção: (?'secao'\d+), aptos: (?'aptos'\d+)\)", flags=re.MULTILINE)
test_str = ("(seção: 509, aptos: 121)\n"
"(seção: 517, aptos: 118)\n"
"(seção: 327, aptos: 89), (seção: 328, aptos: 90)\n"
"(seção: 371, aptos: 89), (seção: 520, aptos: 53)\n"
"(seção: 331, aptos: 111), (seção: 332, aptos: 111), (seção: 334, aptos: 111)\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")