#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^[+]?([0-9]*[\.\s\-\(\)]|[0-9]+){3,24}$"
Local $sString = "011 (416) 457 7845" & @CRLF & _
"+1 (416) 457 7845" & @CRLF & _
"011416457111" & @CRLF & _
"Standard Telephone numbers" & @CRLF & _
"+61 1 2345 6789" & @CRLF & _
"+61 01 2345 6789 (zero entered is not required but enterd by user anyway)" & @CRLF & _
"01 2345 6789" & @CRLF & _
"01-2345-6789" & @CRLF & _
"(01) 2345 6789" & @CRLF & _
"(01) 2345-6789" & @CRLF & _
"1234 5678" & @CRLF & _
"1234-5678" & @CRLF & _
"12345678" & @CRLF & _
"" & @CRLF & _
"^(\+[1-9][0-9]*(\([0-9]*\)|-[0-9]*-))?[0]?[1-9][0-9\- ]*$" & @CRLF & _
"" & @CRLF & _
"^(\+[1-9][0-9]*(\([0-9]*\)|-[0-9]*-))?[0]?[1-9][0-9\- ]*$" & @CRLF & _
"" & @CRLF & _
"^\+([0-9]( |-|\+)?)?(\(?[0-9]{3}\)?|[0-9]{3})( |-)?([0-9]{3}( |-)?[0-9]{4}|[a-zA-Z0-9]{7})$" & @CRLF & _
"" & @CRLF & _
"^((\\+[1-9]{1,4}[ \\-]*)|(\\([0-9]{2,3}\\)[ \\-]*)|([0-9]{2,4})[ \\-]*)*?[0-9]{3,4}?[ \\-]*[0-9]{3,4}?$" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")