using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^The\.Walking\.Dead\.S06.+VOSTFR.+x264";
string input = @"The.Walking.Dead.S06E06.PROPER.VOSTFR.HDTV.x264-3ARLY";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}