// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)^The\.Walking\.Dead\.S06.+VOSTFR.+x264").unwrap();
let string = "The.Walking.Dead.S06E06.PROPER.VOSTFR.HDTV.x264-3ARLY";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}