import re
regex = re.compile(r"^The\.Walking\.Dead\.S06.+VOSTFR.+x264", flags=re.IGNORECASE)
test_str = "The.Walking.Dead.S06E06.PROPER.VOSTFR.HDTV.x264-3ARLY"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")