package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`c.{0,2}?m.{0,2}?`)
var str = `abcemtcmncefmf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}