using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\((\w+)(\w+)?\)";
string input = @" /* # combined # TargetLink outport: SWC_ClutchControlCC/lib_SWC_CC02/S_iBLDCSetPnt */
Rte_Write_SP_ClutchCtrlC02_S_iBLDCSetPnt(V_SpdCtrlC02_iBLDCSetPnt);
Rte_Write_SP_ClutchCtrlC02_S_iBLDCSetPnt((int) V_SpdCtrlC02_iBLDCSetPnt);
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}