import re
regex = re.compile(r"\((\w+)(\w+)?\)")
test_str = (" /* # combined # TargetLink outport: SWC_ClutchControlCC/lib_SWC_CC02/S_iBLDCSetPnt */\n"
" Rte_Write_SP_ClutchCtrlC02_S_iBLDCSetPnt(V_SpdCtrlC02_iBLDCSetPnt);\n"
" Rte_Write_SP_ClutchCtrlC02_S_iBLDCSetPnt((int) V_SpdCtrlC02_iBLDCSetPnt);\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")